Checkbox not working

Home Forums Bugs and Troubleshooting Checkbox not working

This topic contains 12 replies, has 2 voices, and was last updated by  Brian Penner 3 weeks, 4 days ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #23439 Reply

    Brian Penner
    Participant

    Hi, I’m using your plugin to convert a few forms into PDFs. I’m having a problem with checkbox field. One of the options on the checkbox is Hit & Run and it doesn’t transfer to the PDF. I’ve selected the field in the PDF column and I can see it is recognizing it. All the other checkbox options from formidable are mapping over correctly except this one. How do I fix this?

    #23443 Reply

    admin
    Keymaster

    Make sure;
    1. The PDF field is not mapped more than once on the Field Map Layout
    2. The option values are exactly the same by copying the Formidable Form checkbox option value then paste it into the “Export Value” of the PDF checkbox field. (Any extra spaces or characters will not match) Then, upload the PDF to the plugin with the exact same filename to overwrite the existing PDF.

    If you still need our assistance, we’ll need;
    1. The PDF form
    2. A screenshot of the Formidable Form in design view so we can see the option value (and any separate value)
    3. A screenshot of the entire field map layout.
    Or, complete this form and we’ll quickly login/out and let you know where the issue is.

    We remain at your service.

    #23444 Reply

    Brian Penner
    Participant

    Quick question, Is it possible that the ampersand is causing issues?

    #23445 Reply

    admin
    Keymaster

    Yes, although we thought all the special character issues were resolved. If that is the case, we would like to investigate your issue if possible. Can you upload the PRO2PDF template to this form?

    We remain at your service.

    #23446 Reply

    Brian Penner
    Participant

    Sorry, I’m not sure if I understand which information you all need.

    #23447 Reply

    admin
    Keymaster

    It’s optional… If we can find the issue from the PRO2PDF template, then it’s an issue effecting all users. If we cannot find the issue from the PRO2PDF template, then it’s an issue that is limited to your installation.

    So, the less invasive route is for us to check the template. From the PRO2PDF plugin, go to the “Templates” tab, then EXPORT the Field Map Layout that has the issue and upload it here.

    Or, provide login and ftp credentials on this form so we can troubleshoot your installation.

    Or, use Formidable Form’s “Separate Values” functionality as a workaround. (Although, we’d prefer to find/fix the issue.)

    We remain at your service.

    #23451 Reply

    Brian Penner
    Participant

    Ok, I tried uploading it. Not sure if it came through as it said I’d already submitted it.

    #23454 Reply

    admin
    Keymaster

    It appears our FF’s are down after the last update. Please email to support AT formdiablepro2pdf DOT com while we fix our very own FF issue… ..Mondays!

    We remain at your service.

    #23479 Reply

    Brian Penner
    Participant

    Ok, I sent it last night and I’m awaiting your support.

    #23487 Reply

    admin
    Keymaster

    Bug is confirmed, we will work to correct the bug in a future update, at this point we do not have a time frame for the update.

    As a workaround, remove the ampersand sign from the name of the PDF field and all will work as expected.

    We remain at your service.

    #23489 Reply

    admin
    Keymaster

    Clarification: As a workaround, remove the the ampersand sign from the FF and PDF option value. You can also use FF’s separate fields so your display value can include the ampersand sign, but the export value will not.

    We remain at your service.

    #23517 Reply

    admin
    Keymaster

    The latest update of PRO2PDF fixes the issue with merging the ampersand sign. You must update your plugin from the WP dashboard to realize the change.

    We remain at your service.

    #23519 Reply

    Brian Penner
    Participant

    Thanks, that fixed it.

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: Checkbox not working
Your information: